Twilio Telephony and SMS degraded

Incident Report for evalink

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 11:30 CEST

Update

Twilio Voice services have recovered, and seem to be operating normally again.

SMS, Automated Calls and VoIP calls in evalink talos are all looking to be working as usual - we're still keep monitoring until the incident is fully resolved.
Posted Oct 20, 2025 - 14:36 CEST

Monitoring

We're seeing services starting to recover, Automated SMS seem to work again - Automated Calls and VoIP calls are still failing for the most part - we continue to monitor the situation.
Posted Oct 20, 2025 - 12:24 CEST

Identified

Twilio is currently experiencing issues - affecting Calls and SMS from and to evalink talos.

More information can be found here:
https://status.twilio.com
https://status.twilio.com/incidents/2mjg0mr2pf29

We're closely monitoring and working on potential internal workarounds as the incident goes on.
Posted Oct 20, 2025 - 09:42 CEST
This incident affected: 3rd party services (Twilio SMS, Europe, Twilio SMS, APAC, Twilio SMS Toll-Free, North America, Twilio Voice, Europe, Twilio Voice, APAC, Twilio Voice, North America).