evalink EU failing requests

Incident Report for evalink

Resolved

This incident has been resolved.
Posted May 11, 2026 - 15:51 CEST

Identified

There was a high load of UI requests failing from 15:08 to 15:13 - after manual intervention after our internal alerts triggered the system recovered quickly and seems to be stable - we're investigating what caused the component to start failing in this timeframe and have it deactivated for the time being.
Posted May 11, 2026 - 15:32 CEST

Investigating

We're currently investigating an elevated amount of failing requests in our EU region
Posted May 11, 2026 - 15:19 CEST
This incident affected: evalink talos (Region Europe).