evalink login issues

Incident Report for evalink

Resolved

This incident has been resolved.
Posted Apr 22, 2026 - 22:08 CEST

Monitoring

The issue was caused by a DNS problem at the underlying platform provider, emergency login via https://talos.evalink.io/en/login2, remains possible.
From what we can see the DNS started recovering around 10mins ago, and seems fully operation again by now. Only certain regions seemed to be affected.
We're monitoring the situation to confirm that the system stays healthy.
Posted Apr 22, 2026 - 21:02 CEST

Identified

We're aware of login issues at our auth provider:
Use the emergency login at https://talos.evalink.io/en/login2 to login via email code.
Posted Apr 22, 2026 - 20:53 CEST
This incident affected: evalink talos (Region Europe, Region America, Region Asia/Pacific).