Final incident summary: A major power blackout in Southwestern Europe and adjacent regions caused an exceptional load increase on the platform. This resulted in slower service response times between 12:35 and 13:55 as the system scaled up to absorb the load. Some less noticeable slowdowns occurred between 13:55 and 14:04 while further stabilization activities were introduced to support the system in handling remaining background transactions. Alarm transmission and processing remained operational throughout and were not seriously affected. All services have been fully stable since, and we continue to monitor the platform closely.
Posted Apr 28, 2025 - 17:29 CEST
Update
Following an initial analysis, the performance degradation in our Europe region was caused by an exceptionally high load spike triggered by a major external event in Southwestern Europe and partly in adjacent regions. During this period, alarm transmission and workflows remained operational, although there were delays while the system scaled up to handle the increased load.
Services have stabilized and are now operating normally. We continue to monitor performance closely to ensure ongoing stability. Instances in Asia and North America were not affected at any time.
Posted Apr 28, 2025 - 13:33 CEST
Update
We are continuing to monitor for any further issues.
Posted Apr 28, 2025 - 13:14 CEST
Monitoring
The system in our Europe region is stabilizing following the earlier performance degradation. Services, including alarm management and signal reception, are operating normally again. Alarm transmission is currently functioning as expected. We continue to closely monitor the platform to ensure full stability.
Posted Apr 28, 2025 - 13:08 CEST
Update
We are continuing to work on a fix for this issue.
Posted Apr 28, 2025 - 12:57 CEST
Identified
We have implemented corrective measures in our Europe region and are seeing signs of recovery across the affected services. Alarm transmission is stabilizing, but we continue to monitor the situation closely to ensure full restoration. We will share a further update once recovery is fully confirmed or if there are significant changes.
Posted Apr 28, 2025 - 12:56 CEST
Investigating
We are currently experiencing a major performance degradation in our Europe region, which initially appeared as a full outage. Services, including alarm management and signal reception, have remained operational but were severely impacted by high latency. Alarm transmission may have been delayed for customers in this region. Our technical team has implemented corrective measures, and the system is now recovering.
Posted Apr 28, 2025 - 12:49 CEST
This incident affected: evalink talos (Region Europe).