Degraded Performance EU-region

Incident Report for evalink

Resolved

The degraded performance affecting evalink talos in the EU region has been resolved. Our team has confirmed that service performance is operating normally, and this incident is now closed.
Posted Apr 06, 2026 - 18:27 CEST

Monitoring

We have identified the cause of the degraded performance affecting the device-service in Europe and have implemented mitigation measures. Platform performance has stabilized, and our team is continuing to monitor the service closely. Alarm transmission is not affected. We will provide a further update if necessary.
Posted Apr 06, 2026 - 17:36 CEST

Investigating

We are currently investigating platform performance issues affecting services in Europe. Our team is actively working to identify the cause and restore normal performance. Alarm transmission is not affected. We will provide another update as soon as more information is available.
Posted Apr 06, 2026 - 17:25 CEST
This incident affected: evalink talos (Region Europe).